Support Phone Lines Dropping Calls
Incident Report for Ease
Resolved
This incident has been resolved.
Posted Mar 22, 2022 - 12:26 PDT
Investigating
We’re currently working through a service disruption with our service provider which is causing calls to be dropped when answered. Agents are working to provide callbacks as soon as possible as we investigate the cause.
Posted Mar 22, 2022 - 09:42 PDT
This incident affected: Support.