Issues with Sending Emails

Incident Report for Ease

Resolved

This incident has been resolved.
Posted Apr 23, 2025 - 18:17 PDT

Investigating

We are investigating an issue affecting email sending. Due to an outage at the partner service, emails are being accepted and queued for delivery but may be delayed.
Posted Apr 23, 2025 - 15:00 PDT
This incident affected: Web Application.