Background Jobs Processing Performance Degradation
Incident Report for Ease
Resolved
Planned maintenance is complete.
Posted Jan 03, 2024 - 23:15 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 29, 2023 - 07:26 PST
Investigating
We're experiencing performance issues with background jobs processing. Tasks like email sending, forms generation and changes processing may be delayed until we are fully recovered.
Posted Dec 29, 2023 - 05:46 PST
This incident affected: Web Application.