Support Phone System Outage
Incident Report for Ease
Resolved
This incident has been resolved.
Posted Apr 22, 2024 - 10:31 PDT
Investigating
Our phone system is experiencing a temporary outage, impacting our ability to receive calls. During this time, we encourage you to utilize our web form within the Ease Support icon or via help.ease.com to submit any inquiries or tickets to our support team. We apologize for any inconvenience and appreciate your understanding as we collaborate with our phone provider to resolve this issue.
Posted Apr 22, 2024 - 08:19 PDT
This incident affected: Support.