Customer Support Phone & Chat is unavailable
Incident Report for Ease
Resolved
As reported by our service provider, the issue causing the service disruption has been resolved and our phone and chat options should now be working as intended. We look forward to helping you today and thank you for your patience and partnership.
Posted May 19, 2023 - 05:09 PDT
Update
Our service provider has reported recovery at their end and is monitoring to full recovery. We will provide another update once we have more to share. We appreciate your support and patience.
Posted May 18, 2023 - 19:12 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 18, 2023 - 18:22 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 18, 2023 - 17:13 PDT
Investigating
We’re currently working through a service disruption with our service provider which is causing our phone lines and chat features to be unavailable. Please submit a ticket for assistance via help.ease.com and we would be more than happy to assist you with your concerns while we work to resolve this issue.
Posted May 18, 2023 - 16:34 PDT
This incident affected: Support.